¿Está actualizada la versión de jQuery en su sitio de WordPress?

Su tema y plugins, así como el propio WordPress, confían en jQuery. Una versión desactualizada puede poner en riesgo su sitio web.

En este artículo, le mostraremos cómo actualizar jQuery a la última versión de WordPress.

¿Por qué actualizar jQuery a la última versión en WordPress?

Su sitio web de WordPress, así como muchos plugins y los temas que usa, confíe en JavaScript en combinación con jQuery para crear funciones rápidas, interactivas y atractivas.

Es importante mantener jQuery actualizado para mantener la seguridad de su sitio web. La última versión corrige errores y vulnerabilidades en versiones anteriores que pueden poner en riesgo su sitio.

Si está ejecutando la última versión de WordPress, entonces no necesita actualizar manualmente jQuery. Se hace automáticamente por ti. Pero si está utilizando una versión anterior de WordPress, como WordPress 5.4 o anterior, se recomienda que realice la actualización.

Además, si ha reemplazado el jQuery predeterminado de WordPress con Google Library, entonces no se actualizará automáticamente a la última versión.

Nota del editor: es importante resaltar que la actualización de jQuery puede romperse plugin funcionalidad, por lo que después de la actualización, debe probar su sitio web. En la mayoría de los casos, no es un problema, pero en caso de que tenga problemas, puede volver fácilmente a la versión anterior.

Dicho esto, echemos un vistazo a cómo actualizar jQuery a la última versión en WordPress. Esto es lo que cubriremos en este tutorial:

Cómo determinar si su versión de jQuery está desactualizada

Puede encontrar fácilmente la versión de jQuery que su sitio web está ejecutando utilizando la consola de Javascript en su navegador web.

Primero, deberá visitar su sitio web y luego abrir la consola de JavaScript. Si está utilizando Google Chrome, puede hacerlo seleccionando Ver » Desarrollador » Consola JavaScript del menú.

A continuación, debe pegar el siguiente comando en la consola:

jQuery.fn.jquery

Este comando mostrará la versión de jQuery que está ejecutando su sitio web.

Descubra la versión de jQuery que está ejecutando su sitio web

Con suerte, debería ver la versión 3.5.1 o superior. Si su sitio web ejecuta una versión que comienza con 1.7 o inferior, entonces definitivamente debe actualizar.

Método 1: actualice jQuery a la última versión estable

los Actualizador de jQuery plugin actualiza jQuery a la última versión estable oficial. Es probable que sea más actual que la versión que viene con WordPress.

Primero, debe instalar y activar jQuery Updater plugin. Para más detalles, vea nuestra guía paso a paso sobre cómo instalar un WordPress plugin.

Tras la activación, su sitio web comenzará a ejecutar la última versión de jQuery. Sin embargo, antes de ver el cambio, es posible que deba borrar el caché de su navegador y el caché de WordPress.

los plugin incluye el script jQuery Migrate para ayudar con la compatibilidad con versiones anteriores. Sin embargo, si encuentra que tiene problemas con algunos de sus pluginsentonces simplemente puede desactivar jQuery Updater plugin para devolver su sitio a su estado original.

Método 2: controle la versión de jQuery que se ejecuta en su sitio web

los Control de versiones para jQuery plugin le permite controlar la versión de jQuery que se ejecuta en su sitio web. Esto permite a los usuarios de WordPress ejecutar un sitio web estable de WordPress, y los desarrolladores de WordPress pueden verificar si su código funciona con varias versiones de jQuery.

Para comenzar, debe instalar y activar jQuery Updater plugin. Si necesita ayuda, consulte nuestra guía paso a paso sobre cómo instalar un WordPress plugin.

Tras la activación, el plugin se establecerá de forma predeterminada en la última versión preliminar de jQuery. También instala el script jQuery Migrate para ayudar con la compatibilidad con versiones anteriores.

Si lo necesita, puede seleccionar una versión diferente de jQuery visitando el Configuración » Control de versiones de jQuery página.

Elija la versión de jQuery que desea ejecutar

Desde aquí, puede seleccionar las versiones de jQuery y jQuery Migrate que desea ejecutar en su sitio. Asegúrese de hacer clic en el botón ‘Guardar cambios’ para almacenar su configuración.

Si la versión actualizada de jQuery rompe algunos de sus antiguos plugins, luego puede simplemente seleccionar una versión anterior del menú desplegable. Alternativamente, si desactiva el control de versiones para jQuery pluginsu sitio volverá a su estado original.

Esperamos que este tutorial le haya ayudado a aprender cómo actualizar jQuery a la última versión en WordPress. Es posible que también desee aprender cómo aumentar el tráfico de su blog o consultar nuestra lista de los errores más comunes de WordPress y cómo solucionarlos.

, WordPress. Twitter y Facebook.

Cómo actualizar jQuery a la última versión en WordPress .

visto en: wpbeginner

Deja una respuesta

Tu dirección de correo electrónico no será publicada.